18 Oktober, 2016

Ubuntu och ickefungerande USB-modem

I helgen var jag hundvakt hos min mamma och roade mig då med att uppgradera hennes laptop som har en gammal installation med Lubuntu. Jag uppgraderade från 14.04 till 16.10 och förvånande nog nog slutade hennes USB-modem från Huawei att fungera i samband med uppgraderingen.

Det som hände var att Lubuntu hittade enheten men inte ville växla till modemläget. Modem för mobilt bredband har två lägen; i det första läget fungerar den som en vanlig lagringsenhet där man kommer åt drivrutiner och ett sekundärt läge där modemet fungerar som ett modem. Kunde dom inte bara ha skickat med en CD-skiva?

Jag hittade en hel hög med olika tips och idéer som fungerat för andra med varierande resultat, dessvärre inget som fungerade för mig. Jag hittade även några olösta och övergivna buggrapporter på Launchpad med +1 år på nacken. Lite tråkigt att Canonical inte tycks prioritera något så viktigt som fungerande modem för mobilt bredband.

Nåja, efter ett par timmars felsökande hittade jag en fullösning på problemet - Det går nämligen att växla till modemläget manuellt. Det är dock bara temporärt och du måste köra kommandot varje gång du startat om datorn eller pluggat ur modemet.

# usb_modeswitch -J -v 0x12d1 -p 0x157d

Du behöver paketet usb-modeswitch. Flaggan -v och -p står för vendor och product, du hittar rätt värden med kommandot lsusb:

$ lsusb
[...]
Bus 002 Device 015: ID 12d1:157d Huawei Technologies Co., Ltd. 
[...]

Om du har en bättre lösning på problemet får du gärna höra av dig!

Lämna en kommentar:

Namn:

Hemsida (Valfritt):

Meddelande (kramdown-markup tillåtet):

Din kommentar kommer att publiceras när den har verifierats.